After installing MacOS Sonoma Browse/Check for updates on plugins not working

Bug found in personal and sandbox vaults

Steps to reproduce

Browse plugins

  1. Settings | Community Plugins | Browse
  2. Enter a known plugin name e.g. “dataview”
    Actual result: “No results found.”
    Expected result: plugins listed

Check for plugin updates

  1. Settings | Community Plugins | Check for updates
  2. Enter a known plugin name e.g. “dataview”

Actual result: “No results found.”

Expected result: progress indicator visible whilst searching for updates

Environment

SYSTEM INFO:
Obsidian version: v1.4.14
Installer version: v1.4.13
Operating system: Darwin Kernel Version 23.0.0: Fri Sep 15 14:42:42 PDT 2023; root:xnu-10002.1.13~1/RELEASE_X86_64 23.0.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: Things v2.0.1
Snippets enabled: 0
Restricted mode: off
Plugins installed: 100
Plugins enabled: 69
1: Dataview v0.5.59
2: Advanced Mobile Toolbar v1.8.0
3: Advanced Slides v1.20.0
4: Advanced URI v1.38.1
5: Apply Patterns v2.1.2
6: Bartender v0.5.9
7: Breadcrumbs v3.6.4
8: Collapse All v2.0.0
9: Completed Task Display v1.0.3
10: Copy Block Link v1.0.4
11: Creases v0.7.0
12: Customizable Sidebar v2.2.1
13: Dictionary v2.22.0
14: Editor Syntax Highlight v0.1.3
15: Excel to Markdown Table v0.4.0
16: Extract url content v0.12.1
17: Find and replace in selection v1.0.1
18: Find orphaned files and broken links v1.9.1
19: Flexible Pomodoro For Obsidian v0.6.0
20: Folder Note v0.7.3
21: Heatmap Calendar v0.6.0
22: Hotkey Helper v0.3.18
23: Hotkeys++ v0.2.7
24: Second Window v1.1.0
25: Indentation Guides v1.0.8
26: Key Sequence Shortcut v2.0.2
27: Kindle Highlights v1.9.2
28: Link Favicons v1.8.3
29: Metadata Extractor v1.1.0
30: MetaEdit v1.8.2
31: Natural Language Dates v0.6.1
32: Note Refactor v1.8.2
33: Obsidian Enhancing Export v1.9.1
34: obsidian markmind v1.8.2
35: Obsidian Tabs v1.0.7
36: Obsidian42 - BRAT v0.7.0
37: Obsidian42 - Text Transporter v1.0.3
38: Obsidian42 - Jump-to-Date v1.0.14
39: Omnisearch v1.17.1
40: Outliner v4.8.0
41: Ozan’s Image in Editor Plugin v2.2.4
42: Pandoc Plugin v0.4.1
43: Pane Relief v0.5.1
44: Paste URL into selection v1.7.0
45: PDF Highlights v0.0.4
46: Periodic Notes v0.0.17
47: Plugin Changelogs v1.3.0
48: Quick Switcher++ v3.3.7
49: QuickAdd v1.3.0
50: Remember cursor position v1.0.8
51: Reminder v1.1.15
52: Review v1.6.4
53: Shortcut Launcher v1.0.1
54: Sort & Permute lines v0.7.0
55: Tag Wrangler v0.5.13
56: Tasks v4.8.1
57: Templater v1.16.1
58: Workspaces Plus v0.3.3
59: Zoom v1.1.2
60: Calendar v1.5.10
61: Local images v0.14.2
62: Readwise Official v2.0.1
63: Advanced Tables v0.19.1
64: Table Generator v1.4.1
65: Annotator v0.2.10
66: Text Extractor v0.4.6
67: Meld Encrypt v2.3.2
68: Confluence Integration v5.5.2
69: Send Tasks to OmniFocus v1.0.7

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Do you see the same behavior when searching for themes?

Maybe a network or DNS issue? :thinking:

this sounds like a network problem.

Yeah, I’m on Sonoma and don’t see this behavior.

No, browsing for themes doesn’t work either

Obsidian Sync is working fine

How embarrassing. I am guessing that a recent installer and obsidian update switched off the plugin sync options.
I switched them back on, restarted Obsidian and Hey Presto!

Thanks everyone