After installing certain plugins my obsidian instance keeps crashing when I enable Community plugins

What I’m trying to do

after installing certain plugins my obsidian instance keeps crashing when I enable Community plugins. Pretty much can only run Obsidian in restricted/vanilla mode right now. The plugins I have installed are:

Things I have tried

I’ve tried turning off each plugin in turn and it appears Notion Like Tables plugin may be culprit. When I try to uninstall any of the plugins, my uninstall button click does nothing.

I’ve uninstalled and reinstalled obsidian at least 5 times over past 6 months. Been surviving in no plugin mode, but trying to resolve this now if I can…

Appreciate any help you all can give. Love this product and community!

Notion-Like Tables is called Dataloom now, so you have a quite outdated version of the plugin installed. That could have something to do with it.

1 Like

I agree with @Feralflora , just because you can download some plugin, it doesn’t mean that it works too

Always check when plugins got their last and most recent updates.
Plugins older than 1-2 years or less (you’ve to check them individually) usually don’t work anymore and should be color labeled as obsolete

1 Like

Another option: with the vault closed, you could remove or rename the {VAULT}/.obsidian/community-plugins.json file. This will keep all your plugins, but they’ll all be off when you reopen the vault. Then try turning them on one-at-a-time.


It’s not that the plugin is unmaintained or obsolete in this case, @EternalProtege just hasn’t updated it to the latest version (8.1.0), released 16 days ago.

1 Like

Thanks @Feralflora - I realized from your reply that my post sounded quite harsh toward the plugin/plugin creator, which wasn’t my intention. Going to try upgrading. Thanks for everyone’s suggestions and help.

1 Like

@EternalProtege Were you able to get DataLoom to update?

Hey @treywallis - no I haven’t been able to fix this. Just using on vanilla / restricted mode for now. Have uninstalled and deleted, then installed. But each time I uninstall and reinstall, the plugins are there and the issue repeats itself. No worries tho, too busy to dive fully into fixing this properly.

I’ve just become content with restricted mode. I go back and forth btwn iawriter (simplified mobile) and obsidian (richer desktop experience) anyway.

Thanks to everyone for the suggestions…

@EternalProtege Even if you uninstall Obsidian, if you use the same vault folder, it will still have the plugins. I have seen a few issues with people upgrading from Notion Like Tables (< 7.0.0) to DataLoom (8.0.0+). Could you try deleting <your-vault>/.obsidian/plugins/notion-like-tables folder? Then try reinstalling DataLoom and it should work, assuming it’s the plugin as the culprit.

I’m the developer of DataLoom btw

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.