Advanced Tables Not working

Hi,

I’ve installed and activated Advanced Tables.

I’m tryign to go

| English (tabl) and nothing new happens.

I’ve tried restarting it.

Any ideas? I’m pretty new to Obsidian, thanks.

3 Likes

I am having the same issue currently…

1 Like

make sure that advance table plugin is properly configured enabled in Obsidian setting. Access the page setting by go to setting>community plugin>installed plugin>advanced plugin.

It is. I’m experiencing same issue as OP. Frustrating.

same here.

1 Like

Are you guys in live preview or source mode?

If I’m in source mode I can type the sequence of | + space + tab and it’ll present me with a very limited table, but still a table.

If I’m in live preview and type the same, it’ll indent the code into a code block, and not insert the table.

In either case, I believe a better start to building a table in either of the editing modes, is to trigger the command Insert table. Then Advanced table and/or the live preview table editing can be used from then on.

It’s still working for me in soruce mode, but not live preview, which is where I spend virtually all of my time.

I can’t get the advanced table editor to work at all. I follow the instructions and enter | type the label I want, then tab and the whole thing just shifts over. If I type again it just gets added to the end of the previous type and this continues. Enter just moves to another line and I clearly don’t have a table. I have tried uninstalling the editor and reinstalling it. I have the safe mode off to allow the community plugins to work. When I first started using Obsidian it did work and I was able to create a few tables, but now it does not. It is beyond frustrating. It seems so simple, but I can’t get it to work and I use tables a lot. Maybe I will try Logseq, but I would prefer to stay with Obsidian.

I just went back to a table I previously created and it does work. I can add and insert rows and data.
I am using Obsidian version 1.5.12, which is the latest version. The Advanced Tables plugin versions is 0.21.0.

@mclbri , please try using the Insert table command.

If you want to only type to trigger the table insertion in live preview it seems like you at least need to type the following:

| header | header |
| --- 

Then you insert the next | character, it’ll insert the table.


By the way all of the posts so far in this thread is not related to the actual Advanced Tables plugin, but are referring to how to get that initial table inserted into your documents. Further handling and processing of the table can be done using either or both of the initial live preview table handling or the Advanced Tables plugin. Many might be satisfied with the newish live table editor which Obsidian provides by default.

Thanks for your response.

The instructions for the Advanced table plugin are below. (GitHub - tgrosinger/advanced-tables-obsidian: Improved table navigation, formatting, and manipulation in Obsidian.md)

To create a table, create a single | character, then type the table’s first heading and press tab. Continue entering headings and pressing tab until all the headings are created. Press Enter to go to the first row. Continue filling cells as before, and Enter again for each new row.

When I follow these instructions I do not get a table.

If I follow your instructions to create a table, it does create a table. When I use that table, the advanced table palette processes work. I can insert rows, columns etc.

So I can create a table, but I feel so incredibly stupid that I can’t follow the advanced tables process to create one. What am I missing here? Is there something about the “as before” that I am missing? The video clip on the site seems to show entries as I made them.

That Readme.md file was updated 2 years ago, and was precise at that time. And as I’ve said before you can use that simpler method when in source mode, not in live preview.

So the easiest and fastest way to start a table is using the insert table command.

OK got it - thanks. I only recently started using Obsidian and when installing it took the defaults which meant the Live Preview was the mode in effect. I did not know there was a source mode, or what that meant.

I toggled the live preview off and picked source, and the table plugin worked as described. The plugin notes make no mention that to use it to create a table, you must be in the source mode. Since the Live preview mode was out in Nov 2021 I would have thought the notes for the advanced tables plugin would have been updated by now, particularly since the last adv table update was two months ago. Almost everything I saw re advanced tables said just go ahead pipe text tab Enter. I also saw many people with the same problem I had.

At any rate I am now clear on this and thank you for your assistance.

1 Like