Adding internal link after hyphen (bullet list separator) moves the cursor one position forwards

Once you’ve done the above, delete everything above this line.

Steps to reproduce

  1. Start bullet list (either from quick switcher or by entering “hyphen” -character “-”
  2. Add Internal Link -item (either from task switcher or by pressing hotkey

Expected result

Cursor should stay between the double square brackets.

Actual result

After adding internal link, cursor moves forward one position and entering internal link name between correct square brackets gets broken.


  • Operating system:
  • Debug info:
    Obsidian version: v1.1.9
    Installer version: v1.0.3
    Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:15:09 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T6000 22.1.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Minimal v6.1.17
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 20
    Plugins enabled: 19
    1: Advanced Tables v0.18.1
    2: Extract Highlights v0.0.18
    3: Outliner v4.2.0
    4: Calendar v1.5.10
    5: Kanban v1.5.1
    6: Dataview v0.5.47
    7: Obsidian TODO | Text-based GTD v0.2.7
    8: Tag Wrangler v0.5.5
    9: Templater v1.16.0
    10: Natural Language Dates v0.6.1
    11: Various Complements v7.3.0
    12: Excalidraw v1.8.6
    13: Map View v2.2.0
    14: Excel to Markdown Table v0.4.0
    15: Advanced URI v1.31.2
    16: Enhancing Mindmap v0.2.4
    17: Readwise Official v2.0.1
    18: Annotator v0.2.8
    19: Minimal Theme Settings v6.1.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

This was incorrectly reported as Obsidian bug. Was caused by plugin obsidian://show-plugin?id=obsidian-outliner instead.

1 Like

and was corrected in Outliner 4.2.1

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.