Add option to disable LaTeX equations

Use case or problem

Repositories may often have no need to use LaTeX equations, but include monetary values in USD or other currencies using the dollar sign. Escaping every dollar sign with a slash is frustrating and complicates workflow for no reason in this situation.

Proposed solution

Add a switch in either editor options or expose LaTeX as a core plugin if it is one, allowing the user to disable LaTeX in their vault.

Current workaround

I can’t find one, any suggestions welcome!

3 Likes

I don’t see any problems when using unescaped dollar sign to denote monetary values like:

$100, $200, and $300

This renders just as it should. Can you provide an example where you really need to escape the $ sign?

Thanks for the reply! Bizarrely…no. I’m like 90% sure I had some single dollar signs just disappear which was why I escaped them and then opened this issue…but I can’t seem to replicate it now.

Sorry if this is a red herring! Has anyone else had an issue with this?

Maybe you had a double $$?

That makes everything go fixed-width font and different colours and styles so I’m pretty sure it wasn’t that!

I’m seeing a lot of these issues also with text containing dollar signs, it really messes up the text formatting in both the source code and in reading mode. I think it mostly happen when there are characters preceding the dollar sign and punctuation right after, which is how it is formatted in some parts of the world, the amount and then $, as opposed to $ first and then the amount. Since I don’t use Latex, and my text content frequently use dollar signs, I wish I could just disable Latex. Adding an escape backslash is not always a practical solution when you save long external articles. Some examples:

Lorem ipsum dolor sit amet, consectetur adipisicing elit 100$. Lorem ipsum dolor sit amet, consectetur adipisicing elit 100$ Lorem ipsum dolor sit amet, consectetur adipisicing elit

Lorem ipsum dolor sit amet, consectetur adipisicing elit 50$, Lorem ipsum dolor sit amet, consectetur adipisicing elit 50$ Lorem ipsum dolor sit amet, consectetur adipisicing elit.

Lorem ipsum dolor sit amet, consectetur adipisicing elit 40$Lorem ipsum dolor sit amet, consectetur adipisicing elit 40$ Lorem ipsum dolor sit amet, consectetur adipisicing elit

Lorem ipsum dolor sit amet, consectetur adipisicing elit $$ Lorem ipsum dolor sit amet, consectetur adipisicing elit $$ Lorem ipsum dolor sit amet, consectetur adipisicing elit

Thanks!

1 Like

I would like to bump this feature request back up to the top. I frequently have more than one dollar sign in a text string. Obsidian reads this as Latex math and hides the $'s. I would like an option to disable Latex math in a vault or even just in a page.

Are you also using a format where the dollar sign appears after the number or word, as in Ginkgo’s examples? Otherwise can you please share an example too?

And if you aren’t aware, a temporary workaround that you can do right now. Use an escape slash:

100\$ Lorem ipsum dolor
100\$\$ Lorem ipsum dolor

screenshot_2023-12-11_02-57-47

Wow, thanks for the quick response rigmarole. I use special characters in passwords such as the following…

Lo$@r$em

So Obsidian reads the two dollar signs as a latex equation and hides them as follows…

Lo@rem

Of course, if I highlight the text then the two dollar signs become visible. If putting a Latex disable button is a fairly straight forward feature add then it would be great. Otherwise, I can put up with it, but it is annoying.

Hello,

Is there any way to fix the highlighting of this Advanced Tables formula affected by the $?

image

Escaping $ breaks the formula.