A note with few hundred lines of data displays red dots (in edit mode) instead of the actual content and completely blank in 'preview' mode. Cursor placed on any red dot displays "\u0"

Steps to reproduce

This is happening only for a single note, rest of the notes are fine. And, I doubt whether it will be reproducible at your end.

I have just opened the note as usual and I see red dots in edit mode and nothing in preview, when in fact yesterday I have created the note and added hundreds of lines of data (comprising text, URLs and images) copy pasted from various websites. Around an hour ago, I had to force shut-down my laptop while the Obsidian app (and that note) was still open and after the laptop restart when I opened that note, this problem appeared.

Expected result

Actual result

Environment

  • Operating system: Windows 8.1
  • Obsidian version: 0.9.17

Additional information

Screenshot:

1 Like

Are you able to open that .md file with another app? If not, I’m afraid your note may have become irrecoverably corrupted.

I hope you have backups. If you don’t, do yourself a favour and try this plugin, a cloud backup solution or, at the very least, regular manual backups.

We believe that the file got corrupted due to the abrupt shutdown. If this happens again, please let us know.

No, I am not able to open that file in any other program (I have tried opening in Notepad, MS Word and in Adobe Reader). I mean the file opens but everything is blank, in MS Word, an 11 page document opens, but then it’s completely blank. Alright, I will try the plugin suggested by you. Thank you.

Yes, even I think the same. Just for your information, my laptop has undergone forced shutdown many a times since the time I have started using your app, but this is the first time something like this has happened. And, your app is always open on my laptop as I add new notes to it almost everyday.
Sure, I will let you know in case this happens again. Thank you.

It happened to me just now, Straight up came to this site. unable to fix it.

I see you are using 0.11.9. See if the file recovery plugin can help you with this. Settings->File Recovery->View-> Search your note water.

Did you also have an unexpected shutdown or something like that?

Oh, Yeah it worked. Spent 4 hours making the notes.
Thank you!.

1 Like

By the way, yes. i also had an unexpected Shutdown while i was using the obsidian.

Hit this problem with a file today.
Minor issue since I have versions and backups.
But I can’t remember the last time I’ve hit a similar problem using other programs.