A big number of plugins make Obsidian slow (Community plugin settings & Command palette)

Steps to reproduce

To be honest, I don’t know how much it’s reproductible, as the bug only appear when using a lot of plugin.
In my case, I have 80 plugins where 60 are activated.

The slow bug doesn’t happens in the sandbox vault.

The bug appear only when searching:

  • A plugin in the community plugin
  • A command in the command palette

Did you follow the troubleshooting guide? [Y]

Expected result

The typing is quick and the command appear quickly

Actual result

A large slow when typing (maybe caused by the fuzzy ?)

Environment

SYSTEM INFO:
    Operating system: ios 17.2 (Apple iPad)
    Obsidian version: 1.4.16 (114)
    API version: v1.4.16
    Login status: logged in
    Catalyst license: insider
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: AnuPpuccin v1.4.5
    Snippets enabled: 36
    Restricted mode: off
    Plugins installed: 80
    Plugins enabled: 61
        1: Excalidraw v2.0.6
        2: Wrap with shortcuts v1.5.0
        3: User Plugins v1.3.0
        4: Templater v1.18.3
        5: Tagged Gallery v1.6.2
        6: CodeMirror Options v0.9.5
        7: Commander v0.5.1
        8: Customizable Menu v2.2.0
        9: Dataview v0.5.64
        10: Folder notes v1.6.13
        11: Group Snippets v1.10.1
        12: Hider v1.3.1
        13: Home tab v1.1.2
        14: Iconize v2.8.0
        15: Obsidian42 - BRAT v0.7.3
        16: Quick Switcher++ v3.3.9
        17: Style Settings v1.0.7
        18: Tabout v1.0.0
        19: File Property Enhancer v1.1.0
        20: Advanced Paste v2.7.0
        21: Cache Area v0.1.1
        22: Plugin Groups v2.1.0
        23: Custom File Explorer sorting v2.1.2
        24: Regex Mark v1.4.1
        25: Editor Syntax Highlight v0.1.3
        26: Front Matter Title v3.7.1
        27: Kanban v1.5.3
        28: Sortable v0.3.1
        29: Supercharged Links v0.11.1
        30: Hotkey Helper v0.3.18
        31: Double Colon Conceal v1.2.2
        32: Create Note in Folder v1.8.0
        33: Canvas CSS class v2.2.2
        34: Open Plugin Settings v1.1.1
        35: Minimal Theme Settings v7.3.1
        36: QuickAdd v1.6.1
        37: Advanced Tables v0.19.1
        38: Admonition v10.1.1
        39: File Info Panel v1.3
        40: LanguageTool Integration v0.3.4
        41: Github Publisher v6.11.5
        42: Clear Unused Images v1.1.0
        43: PARA Shortcuts v1.0.6
        44: DB Folder v3.5.0
        45: Latex Suite v1.8.10
        46: Image Inserter v0.6.2
        47: Linter v1.21.0
        48: Persistent Links v0.2.0
        49: Attachment Management v0.8.5
        50: Keyshots v2.1.0
        51: Icon Folder Yaml v0.0.1
        52: Better Search Views v0.2.2
        53: Better Canvas Lock v0.0.13
        54: Share Note v0.8.3
        55: Canvas Send to Back v0.0.4
        56: Projects v1.17.1
        57: Obsidian Columns v1.5.2
        58: Restore Tab Key v1.12.0
        59: Modal forms v1.27.1
        60: Format Hotkeys v0.1.7
        61: Enhanced Copy v0.2.2

RECOMMENDATIONS:
    Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
    Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

/

Just to check: this report is about iOS/iPadOS only?

There’s no Sandbox vault in mobile Obsidian (unless you copied one over to test).

We don’t take BR involving plugins.
You are gonna need to use divede and impera (there’s a plugin) and figure out which plugin is causing this.

I don’t think it’s caused by a specific plugin but because of a big number of plugin

Yeah, sorry, I mean a “empty” vault without plugin

I didn’t know there was a Divide and Conquer mass toggle plugins “plugin” so thanks for mentioning it.

(I am currently looking at your 60 to see which I have not tried :laughing:)

Since maybe I am also having a similar issue the last couple months, that the interface seems slow or sticky and using a lot of cpu, but can not figure what it might be doing.

Opening the Developer Console with CMD+SHIFT+I and looking for red text might help you further. Try deactivating plugins with names coming up in red text there.

Also, just a hunch: do you have Settings Search plugin on?
I’ve deactivated it and I do similar janitor jobs every month or so and after plugin updates (I roll them back to earlier versions when I feel something’s off – force of habit with me now).

Oh, these are general observations for PC – just seeing now it’s an iOS thread (no dev console there).
Anyways… You can do checks on PC and only use on mobile those that are working well on PC.
Good luck

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.