Zoom level independency per current open note

Use case or problem

When I’m writing a note I usually have multiple other notes opened for that the initial note links to. These extra notes are often a lot shorter than the main one. I usually have the font size pretty large just because it reads nice for short notes, but the larger initial note is too long to pleasantly read.

Proposed solution

Using ctrl + scroll still changes global zoom level, but using another shortcut (like ctrl + alt + scroll) changes relative zoom level of the note that us currently hovered over / active.

Store the relative zoom level so when a note is opened it retains it’s preferred zoom.

Have a button / shortcut to remove the relative zoom of a note so it can turn back to the global zoom level.

Current workaround (optional)


Related feature requests (optional)

Couldn’t find any.

You can control font size per note with CSS snippets. You should be able to set YAML metadata or a tag (like #longnote) and style notes based off of it (with use of a plugin, at least).

There is also a plugin that styles the active note differently. I don’t know if it lets you set custom styles.

If you’re willing to work with YAML and CSS, it’s not that hard to set a custom zoom level. (I don’t know about the button, though.)

First, add a custom CSS class in YAML.

Go in the file that you want to set a custom zoom to, and add something like this at the top of the file:

cssclass: "custom-zoom"

YAML refers to what you write between these --- at the top of your file.

Second, add a CSS snippet to modify that new class you just created.

  1. Navigate to [your vault name here]\.obsidian\snippets. There, create a text document but change the TXT extension to CSS. Name it something obvious, like “custom-zoom.css”.

  2. Open it and write something like this:

.custom-zoom {
  zoom: 125%;
  1. Close the file.

  2. Open Obsidian and go to Setting, then Appearance, then CSS snippets. Click the refresh icon on the right. You should then see your CSS file below the “CSS snippets” title. Toggle it.

And that should do the trick. (At least it worked for me).

PS: I mange my CSS snippets with this immensely useful plugin.