Zettelkasten prefixer stopped creating notes

I installed the Zettelkasten prefixer and used it to make a few test notes…then I changed some other settings elsewhere in the system, and now the prefixer won’t work at all. It doesn’t even create a note.

I’m on a 2020 M1 MacBook Air
Big Sur (macOS 11.4)
Obsidian v0.12.19
running sync with two other devices (a 2020 iMac and an Android Pixel 2)

Things I have tried

I’ve tried turning off all other plugins, close/reopen Obsidian, turn prefixer off and on, removed all custom settings for prefixer. I also tried disabling other settings I had tweaked, but I don’t remember exactly what I did (I did too many things).

I can’t find a way to put everything back to default (I searched for default and/or settings, and prefixer), and I’m too new to know what else might be good to try.

I turned the prefixer on in a vanilla test vault and it’s working there, as it was when I first enabled it in the original vault where it quit working. So I gather it’s something about my vault that is messing it up.

Oh yeah, I also tried making notes from different views (like with no note open vs with a note open) and used the icon in the left sidebar as well as a hotkey. Still no joy.

What I’m trying to do

I want to have notes labeled with the date and time when I start, just in case I forget or don’t feel like giving them a title.

Problem identified/solved: Zettelkasten prefixer does not like having a colon between HH and mm. You can do HHmm but not HH:mm. It also is less than happy when you do just YYYY. It is dazed for many seconds, but recovers and creates the note. My problem is solved by using YYYY-MM-DD HHmm (or YYYY-MM-DD_HHmm_)

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.