YAMS code disappearing in reader mode - im desperate :(


This is my current settings:

This is the simple YAML code I want to use

And this is the output when switching to reading mode:

What the hell is going on? :frowning_face:

Hi @maxalexander , welcome to the Obsidian community!

My first thought is that you might have a theme that’s interfering with your YAML properties.

Could you try going back to the default theme and see if the properties reappear?

hey craig!

Thanks for your answer - guys like you are 100% awesome!!! :smiley:

I already tried that, unfortunately without success.

Thanks! That helps narrow the search a bit.

Any chance you’re using any custom CSS? If so, you could try turning them all off and restarting Obsidian:

Likewise, try temporarily disabling all your plugins in case one of them is interfering with how properties are supposed to render.

:frowning:

Also, my PlugIns dont seem to crazy so far. I got NO IDEA why I keep messing up my obsidian :smiley:

If you would, please try disabling your plugins (or turning on Restricted Mode) and restarting Obsidian. That would help us rule out plugins as the culprit.

Still the same issue.

Is there any possibility to just start from scratch and copy a working setup?

All I really want to do is to use Obsidian for my PHD with zotero and do my Diary with daily notes - somehow I keep on watching Obsidian Youtube Videos and things just don’t seem to work out in the end.

Im getting desperate…

If i add - - - to every second line it suddenly seems to work.
WHAT THE HECK IS GOING ON?!?! :smiley:

This:

Leads to this:

… which seems great! :smiley:

It is working now and i have no idea how this is different to before. Feel very alienated to this, but still THANK YOU SO MUCH! :smiley:


Great! I’m glad you got it working.

I’m not sure what the issue was, but in playing around with it I notice that if there’s an error in the YAML code it won’t render in reading mode. The only clue to the problem was that the Properties view read “invalid properties”.

So my best guess is that there was something wrong in your YAML code, though I can’t guess what it was.

3 Likes

I just donated EURO100 to Doctors Without Borders because you guys are 100% fabulous!

1 Like

It might have just been a sneaky syntax error. Glad you got it sorted! :raised_hands:

If it ever happens again, may I suggest copy/pasting the Source Mode code here to the forum, rather than a screenshot? Then we could try pasting it into a note and see if the problem happens on other computers too. If you surround it with triple backticks, we can copy the code

```
---
YAML here
---
```
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.