YAML not working after Obsidian update on macOS

What I’m trying to do YAML is not working seen I update Obsidian on my macOS, however, it is still working on my iPad and iPhone but they are fully syncing across iCloud.

I am not sure of the problem, so I am not sure where to start looking. Below are the screenshots are the templates and YAML and what happens when it is applied. This happens across all templates on my macOS but not my iPad or iPhone.



Things I have tried

Honestly, the only thing I had tried is change my macOS date but that did not help. Any help or direction is greatly appreciated.

A valid property needs to be in the name: value format, and neither of your date/time follows that template. So you need to change your templates into something like:

---
createdDate: {{date}}
createdTime: {{time}}
title: {{title}}
author:
---

And if you’ve used your old templates on many notes you need to change them accordingly to make their properties valid.

I was using this to created a number with a specific format, as an identification number, with the following format YYYYMMDDHHmm created when the template was applied. It appears with the new properties, it does not allow this and if I want to keep this number identification system, I will have to create it myself as a text or number. I am unsure, how this has affected all my previous notes. Sorry, I did not explain the issue very well, but thank you for trying to help. I was so lost trying to figure this out.

Do feel free to create that unique number, but that’s still a value, and you need to put into a field with a given name for the property to be valid. And that’ll make your YAML valid and functional again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.