With Wikilinks disabled, wikilinks are still created if full filename is typed

Steps to reproduce

  1. Open Sandbox Vault.
  2. Click Settings > Files and Links > Use Wikilinks > Toggle OFF

On any note open, start creating a wiki link to already existing note of the sandbox vault → Start Here

Start with typing the full link as [[Start Here]]. Do not press enter or tab, just follow through and type with starting brackets and with ending brackets.

Now on the next line type partial link, viz type [[Start H and instead of typing through all, select the link to Start Here note and press tab or enter. The link is now properly created as [Start Here](Start%20Here.md)

Did you follow the troubleshooting guide? Yes

Expected result

I expect, for the first way of typing out the full link to get auto converted to the way second link was filled automatically

Actual result

The first link just become a Wiki Link, instead of becoming []() type link.

Environment

SYSTEM INFO:
Obsidian version: v1.4.12
Installer version: v1.4.5
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:22:52 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T8103 22.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information

Open a Feature Request for this.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.