With "Auto pair brackets" turned off, closing `]]` still created automatically upon entering `|`

Steps to reproduce

Disable “Auto pair brackets” in preferences.

Then, in a note, start writing a link to a note, including a | character, e.g.: [[filename|

Expected result

I’d expect not to have the ]] automatically inserted, since (to my understanding) I’ve disabled that behaviour.

Actual result

The ]] is inserted automatically, so we have [[filename|]] with the cursor between | and ]].


  • Operating system: MacOS 10.14.6
  • Obsidian version: 0.6.5
  • Using custom CSS: no