Windows key stops working after opening obsidian

Things I have tried

I tried getting my windows key to work with obsidian many times, but it stops. Seems like there is a glitch.

What I’m trying to do

Did you ever solve this? If you want some help, please post your “Show debug info”.

And maybe also, what language/region in your keyboard set to?

Does it happen in the Sandbox help vault too?

Do you have any hotkey remapping? For example, I have an Apple keyboard. So in Windows, I remap Command and Option to be opposite using PowerToys, so the “Windows” key is in the middle. But if I ever run an app as administrator, then that mapping gets temporarily lost. (Not saying this is your issue. But it might be a clue.)

@rigmarole I have the same exact problem, I would post my “show debug info” but I don’t know where to find it. Anyway my keyboard is set to Italian. I do use a remapping to have easier access to characters like ` and ~, but the windows key doesn’t work even with the standard keyboard or in the sandbox vault.

Help > Show Debug Info

1 Like

thanks to @anon63144152 here’s the debug info:

	Obsidian version: v1.1.16
	Installer version: v1.0.0
	Operating system: Windows 10 Home 10.0.22623
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 1
	Plugins enabled: 1
		1: Excalidraw v1.7.25

I did try to disable excalidraw, but the problem presists


The installer is out of date, as is Obsidian itself. Might help to grab the latest versions:

just tried that but still no luck. two things I noticed though are that

  1. I use windows 11 but the debug info shows windows 10
  2. even though the windows key does nothing the virtual keyboard still detects it when I press it

very weird…

1 Like

Hope someone can help.

alright looks like reinstalling the whole program fixed it… Alas, the solution was much simpler than I thought, yet it never crossed my mind

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.