📊 Will you keep "inline title" on?

You can use this CSS Snippet to hide the inline title in All Views:

.hide-title.markdown-preview-view .inline-title,
.markdown-source-view .inline-title {
display: none;
}

Thanks for sharing this!

Do you know if there’s a way with CSS to affect only files with a certain attribute? I’d like to do this on a case-by-case basis — using a tag, for instance, or a folder. Isn’t there some kind of pseudo element that would look to see if the file path contains a particular word, for example?

Can’t help you with that, sorry. I do the basic “write the cssclass into the yaml of the note the css should be to applied to” thing, that’s enough for me.
By the way, I made a tiny mistake in my last post. Here’s the fully working version:

.hide-title.markdown-preview-view .inline-title,
.hide-title.markdown-source-view .inline-title {
display: none;
}

2 Likes

Thanks anyways! I appreciate the snippet! I forgot about the cssclass attribute… :slight_smile:

The Auto Class plugin can do it based on file path.

1 Like

image
I’d much rather be able to turn the new “not-inline title” off, as it pushes the entire document all the way to the right, making for some pretty nonsense alignment.

Is there a way to do so? I’m using minimal theme on Linux with obsidian installed thru flatpak.

I’ve made the title as small as possible in the meanwhile to push the document the least far right, with the Style Settings extension. Many of the Style Settings settings appear broken with the latest release however.

Make sure all your plugins are up to date and you don’t have any snippets that might interfering with the new V1

I’m also using minimal theme on Linux and did not have this problem. I turned off the new auto title feature anyway.

1 Like

Yes, I’ll keep using it, because it’s really easy to just type one time, and it applied to file names and titles.
Others that bothered by this feature because this feature coming later, and they already have manually typed the H1 so they have redundancy.
For me that just using obsidian lately, it’s a really helpful feature.

Are you using the latest version of Minimal? Settings > Appearance > Check for updates

You can also turn off the title in Settings > Appearance

Thanks for the advice. There was an offending plugin. I should have thought to bisect-check my plugins.

In case anyone else lands here,
Embedded Note Titles by mgmeyers caused the display issue.

The extension appears to have been already removed from the community extension list.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.