Why isn't the : character allowed in note titles?


I’m a recent convert from Roam Research, and a very large number of my notes (~1k) include the : character in the title. After importing those notes into my Obsidian database, the : character still appears in the title, however I can’t use the : character for new notes.

I took a look at the settings but couldn’t find an option to configure this (artificial?) limitation, is there a way to disable this check?

I’ve also installed the mobile app, and it fails to sync any files with a : in the name. Is the solution to this just to rename the files?

Pretty sure it’s because Obsidian uses the note title as the file name of the underlying markdown file and the : character is a path separator on MacOSX, thus an illegal file name character.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.