Why is Obsidian 1.1.6 only using 1.0.0 installer?

Is there a reason why Obsidian 1.1.6 has downgraded the installer to v1.0.0?

I’ve just downloaded (again) from Download - Obsidian, and by using this install I’ve lost the Electron 21 (and Chrome 1.0.6) modules, which I’m kind of depending on for some CSS stuff related :has().

Could someone please explain why the installer was downgraded, or how I can get another package which has a newer installer? (I’m on macOS 10.14 (mojave))

Or would this be considered a bug when packaging the 1.1.16 version for macOS?

are you using homebrew?

I tried installing from that link. I deleted my old app, and my old ~/Library app settings. And I also tried installing from Homebrew.

I can’t reproduce this. It installs 1.1.16, Electron 21.4.1, Chrome 106.0.5249.199 for me.

But I’m on MacOS 12.6.3, so I don’t know if that is a factor.

This is a silly question, and I’m sorry to ask. But are you sure you are selecting the right DMG in your Downloads folder? (I don’t expect you are, but it has to be asked.)

I didn’t delete any library settings, so that might affect stuff.

I do believe I chose the correct package to install from, as I’m only having a few packages within my download folder.

I didn’t use homebrew for this. I just downloaded the entire package directly from the mentioned website.

I’ll retry tomorrow to re-download and reinstall from the website. I did get it working by using an older package, and upgrading internally, but I’m keen to discover why this happened and if I can reproduce it.

Now I really don’t know why my installer was downgraded last night. Now it seems good again.

I’ve done the following to re-test my installation:

  • Removed Obsidian from my Programs folder,
  • Deleted the ~/Library/Application Support/obsidian folder
  • Emptied the trash bin
  • Moved away my previous downloads, and re-downloaded the Obsidian-1.1.16-universal.dmg
  • Installed it, and had to open my vaults (one by one, which was expected)

And now it does show v1.1.16 on both Obsidian and the installer.

So all is good, except for me having the v.1.0.0 installer a few hours yesterday. Kind of strange, but I can live with that for now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.