Why does @Computer result in "Invalid date"? How to fix?

What I’m trying to do

Transfer Getting Things Done (GTD) to Obsidian.

In particular, contexts begin with “@,” so I’m trying to type a list of tasks (using the Tasks Plugin) with contexts assigned. E.g., “@Home”, “@Work”, “@Computer”, etc.

I suspect the problem may be related to an installed plugin. In particular: Tasks, Dataview, or Templater. But thus far, I’ve been unable to track it down.

Things I have tried

Besides typing contexts in tasks, I’ve tried typing contexts on a normal (non-task) line. But I always get an “Invalid date” message, and then [[Invalid date]] replaces the context.

Terms for which I’ve searched

@, “Invalid date”

1 Like

Natural Language Dates perhaps?

That was it. I disabled NLD, and now things work. With a bit more investigation, I reset the Autosuggest trigger to “@@”. Hopefully this will serve for a long while, and when it becomes obsolete, I’ll remember where the problem lies. :laughing:

Thank you! :people_hugging:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.