When exporting to PDF obsidian freezes

Steps to reproduce

Click export to PDF,
Obsidian now freezes for a long time for me.

Expected result

Press export to PDF
Obsidian creates a PDF without freezing, or at least not for long

Actual result

Obsidian freezes


  • Operating system: Windows 10
  • Obsidian version: v.0.10.7

Additional information

I am not using any plugins nor curently using community themes but using dark theme.
the document is here, just in case Handig.zip (457 Bytes)

I used to have this problem too. It happened for the very fist pdf I tried to print and then it worked smootly. The problem was fixed when we upgraded electron. I suggest you grab a fresh installer from the website and reinstll obsidian. Let me know if it helps

1 Like

ill try,

It still freezes when trying to export to pdf, but it doesn’t freeze for every file, so maybe its something with the file?

Does it happen with default css and no thirdparty plugins?

yes, i have no other themes on than the standart dark, and i don’t have any plugins

send a file where this happens. I can’t repro with the file you attached. What’s your installer version?

the file where it happens is the one attached in my post, and i am now using instaler version v0.10.7 (before not but updating didn’t help)

hi i was doing some testing for this as also saw it happen on other window computers, and i think i found the fix :slight_smile:

if you goto your services (start>run>services.msc)
you can check if you have “print spooler” running, before you launch obsidian and try to export…

basically when the print spooler is not running, it hangs on export
(but sometimes it is best for servers etc to not always have it running)

and then when you need to export, you can enable it and it seems to export fine :slight_smile:

fingers crossed this works for you, (and if the devs are happy, can i have a obsidian license? :slight_smile:

if not, can i ask for a couple of small features??
i have been listing some bugs and features within obsidian itself, and will try and check them again and export to a pdf for you :slight_smile:

Feature Suggestions.zip (920.3 KB)


Hi! I have just started to experience this issue on Windows 10! Earlier I did not have any problem with exporting to PDF.

Can this be explained by the “Windows 10 Printnightmare”?

I checked that the Print Spooler is disabled and I cannot start it. I believe that our university has disabled it on all computers.

Thanks in advance for your ideas! :slight_smile:

1 Like

Yes! This was due to Print Spooler having been disabled by the university. Enabling it, fixed the problem for me.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.