When creating note from template, created date is that of template rather than the new note

Steps to reproduce

  1. Create a template note (e.g. for a daily note).
  2. Create a note from that template (e.g. a daily note).
  3. Notice that the created date for the new daily note is that of the template.

Did you follow the troubleshooting guide?

Yes. The bug still happens in restricted mode.

Expected result

When I create a note from a template, the created date for the new note should be the date I created it!

I suspect this is happening because the fact that the template note already has a created attribute in its front matter means the new note isn’t getting a fresh created attribute.

The result of this in my case, for example, has been that all of my daily notes have the same created date. This makes it impossible to sift through them based on created date, and it’s messed up a bunch of data views that I built based on created date. It’s a bummer :frowning:

Actual result

The new note’s created date is the template’s created date.

Environment

SYSTEM INFO:
	Obsidian version: v1.5.3
	Installer version: v1.4.14
	Operating system: Darwin Kernel Version 23.1.0: Mon Oct  9 21:27:27 PDT 2023; root:xnu-10002.41.9~6/RELEASE_X86_64 23.1.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: off
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none

I would so appreciate a fix for this! Thanks.

I would include the template you are using as well; you can put it in a code block (just like in Obsidian) so the forum doesn’t try to render it.

Please detail the steps you use to create a note from that template. Can we safely assume that you use the default “Templates” plugin?

Thanks @ariehen and @vanadium for your replies. And now I feel very dumb :melting_face: From what I can tell, the Update Time on Edit plugin I was using was forcing the override of created and updated in the template file. I don’t know how I missed this because I definitely tested in restricted mode (with that plugin disabled) but apparently I must’ve not had that mode on when I thought I did. When I exclude my Templates folder from overriding created the problem goes away.

Sorry for the bother!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.