Weird interaction between iPad app and Working Copy

Edit - Solved

I contacted the dev from the Working Copy app and provided some of my files. He managed to identify the problem (as expected it was a normalization problem) and it is now fixed in the next release of the app (and the Beta). Great interaction with the dev, he was very helpful, thanks Anders !!

Conclusion : if english is not your native langage you can now be confident that Working Copy is a good solution to sync your vault !

TLDR : I have weird interactions between Working Copy and the iPad app preventing my from syncing the way I would like

What I’m trying to do

I have been using Obsidian for a while now on the desktop (on a Windows computer). Being French, my notes are writen in French (makes sense, doesn’t it ?). As a consequence, some titles have accents.

My vault is also a git repo, I use Working Copy (with the sweet sweet shortcuts support) to sync it with my iPad pro access it on the go through 1Writer.

I got excited about the iPad Obsidian app, so I upgraded from insider to supporter to try it. Inside Working Copy I tried to folder sync with the Obsidian folder and that’s when things got strange…

The weird stuff

  • The folder things starts normally but then about 15/20% of the notes are 1. copied into the Obsidian folder / 2. deleted in the Obsidian folder / 3. deleted in working copy to mirror the Obsidian folder.
  • I tried setting up another vault / another repo / differents combinaisons of files / etc… it looks like only the same files are causing this problem. It looks like they all have accents in them.
  • If I create a file in Obsidian iPad that has the same name as a problematic file from Windows it does not create a problem.
  • If I revert click revert in Working Copy on a file that is now marked for a delete commit, it reverts back to being normal and is again deleted after a couple of seconds.

What I think (but I need help !)

Is it possible that all that is just a mess in Unicode standards between the Windows vault and the Apple (iPad) vault ? It’s the only thing I think about… but i don’t know how to resolve it !!

Does anybody have any ideas ?

I don’t think its accent in fact because I have the same problem, and as a nerd, I prevent using accent in my title (french here too hello).
I send a mail at the developer about this problem, and he doesn’t respond yet. Also, is your Ipad quickly became hot too ? Because mine, yes.

For the moment, the only trick I found is to create shortcut who pull/push when I open app. It works very well in fact.
If only goodnote support pdf save in icloud ;_;. For the moment, I’m thinking about buy the sync because, seriously, i’m bored with this.

Ah, and you can find my tutorial here. If you use it with Obsidian, can you send feedback? I want to know about this trick before paid !

Salut Mara-Li,
Thank you for your answer. I think your problem is different, because mine only happens when I am going for the Folder Sync in Working Copy. I am already using shortcuts as you describe with another app and Working Copy and it works fine. The obsidian app does not support choosing the path of your vault on iPad OS, wich is why I had to use the Folder Sync trick…

Update : my problem is definitly linked to the title of the files. If I create on the Github webapp a file with the same name as one of the problematic file, I have the same issue of auto-deletion.

Okay ! Good to know.
So I need to continue to investigate about my folder sync problem…

UPDATE : Thank you, @bordache because it was my problem with Working Copy ! After rename all my files (god bless Power Rename and regex), the app sync…
To bad because I just take (to test) obsidian sync x). I’m just a little bored to pay 2 clouds (I use Google Drive a lot) but I think it’s okay because I think Git it’s not good to sync files like that (like hundred of note and PDF).

Glad I could help Mara !

I don’t want to change my files name (they are full sentences and I want them to be correct french) so I will keep messaging Working copy dev…

** UPDATE **

Technical background : Unicode encoding and file systems

Here is a couple of things I think I understood while troubleshooting !

There is two ways to encode special characters (like accentueted letters of the French language) :
- NFC (for Normalization Form Composed) where the character is directly represented over two points : é is encoded as its own thing ;
- NFD (for Normalization Form Decomposed) where the character is represented by the base symbol followed by a modifier over 2 points (so 3 total) : é is encoded as e followed by ‘.

Basically Apple uses NFD and everybody else uses NFC.

iPadOS (and MacOS since 2017) is using the APFS file system (standing for APple File System). The previous file system on Apple computers used to normalize every file name to NFD. Although it brings some improvements in some aspects, APFS does not normalize anymore and let the developpers handle that matter…

My understanding of my bug

I think that basically the file name containing accents encoded in NFC is changed to a couple of random character during the transfer. These files are then rejected by the file system and the cloned repo in Working Copy is updated to reflect that deletion.

To go further

I don’t have the technical know-how (and the time) to carry on investigating this right now, but it feels like it is definitly more on the Working Copy side than on the Obsidian side of things. I emailed the dev and will post the answer here if I have something. In a perfect world I could also write a script to normalize to NFD before pushing my changes but it’s too much for me.

I could get rid of all the special character in my titles, but I quite like to use sentences (as an API, thanks to Andy Matuschak) and I want them to be correct as French.

1 Like

** UPDATE **

Anders, the main dev on Working Copy, has been in touch and is very eager to work on that bug. I provided all my files so he could have a look ! Fingers crossed

Solved by Working Copy dev !!

I edited the first post to reflect the solution.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.