Vim Mode search results in a "invalid regex term" and breaks Vim mode for that note

Once you’ve done the above, delete everything above this line.

Steps to reproduce

I have an issue in 1.1.3 with Vim mode enabled: If I search for a term by pressing “/any_term”, when I press enter the message “invalid regex term” is displayed. Thereafter, pressing ESC will not take me back to Normal mode in that note. In other open notes, I can shift between normal mode and insert mode. Have to reopen the broken normal mode file to get the desired behavior. This occurs with all plugins disabled also and it occurs in the Obsidian sandbox vault after I enabled Vim mode.

Expected result

Find the matching terms in the note.

Actual result

“invalid regex term” displayed


  • Operating system:
    Windows 10
  • Debug info:
    Obsidian version: v1.1.3
    Installer version: v1.0.0
    Operating system: Windows 10 Pro 10.0.19045
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Minimal v6.1.15
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 30
    Plugins enabled: 28
    1: Advanced Tables v0.18.0
    2: Creases v0.6.5
    3: Dataview v0.5.47
    4: Dictionary v2.22.0
    5: Emoji Toolbar v0.3.2
    6: Filename Heading Sync v1.7.0
    7: Natural Language Dates v0.6.1
    8: Periodic Notes v0.0.17
    9: Quick Switcher++ v2.3.4
    10: Templater v1.16.0
    11: Vault Statistics v0.1.3
    12: Pane Relief v0.4.1
    13: Pandoc Plugin v0.4.1
    14: Outliner v4.1.1
    15: Quick Explorer v0.2.7
    16: Relative Line Numbers v2.0.1
    17: Search Everywhere v1.0.10
    18: Tag Wrangler v0.5.5
    19: Workspaces Plus v0.3.3
    20: Style Settings v0.4.12
    21: Minimal Theme Settings v6.1.0
    22: Note Refactor v1.7.1
    23: Omnisearch v1.9.0
    24: Calendar v1.5.10
    25: Obsidian Link Converter v0.1.4
    26: Hover Editor v0.11.8
    27: floating toc v2.2.5
    28: Obsidian42 - Strange New Worlds v1.1.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

1 Like


will be fixed 1.1.4

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.