Vim mode + RTL language - wrong character blinks

Steps to reproduce

  1. Open the Sandbox Vault.
  2. Open Settings | Editor and turn on Vim mode.
  3. Type a simple text in an RTL language, e.g. “אבגדהוזח”.
  4. Switch to Vim Normal Mode (Esc) and put the cursor on one of the Hebrew characters.

Clarification: this is not related to RTL mode.

Expected result

Just like in LTR languages, the expectation is that the highlighted character will blink.

Actual result

The blinking cursor mixes the character with the character on the left. Every time the cursor blinks purple, it shows the character to the left instead of the one under the cursor.
This is really disturbing for managing any text in Hebrew, Arabic or Farsi with Vim mode.

Environment

  • Operating system: Linux
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.1.12
    Installer version: v1.1.9
    Operating system: #1 SMP PREEMPT Mon Dec 19 13:16:06 UTC 2022 5.4.228-1-MANJARO
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on

RECOMMENDATIONS:
none


Additional information

Peek 2023-01-25 20-15