VIM-mode: Pressing 'o' should create new item when in a list

Steps to reproduce

  • Activate VIM-mode
  • Start writing a list
  • Press escape to enter command mode / leave insert mode
  • Press ‘o’ to open a new line

Did you follow the troubleshooting guide? [Y/N]

Yes, I tried it in the sandbox vault.

Expected result

A new list item is opened.

Actual result

A new line is opened under the list. Hitting backspace and pressing enter is then required to add another list item.


Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Windows 10 Pro 10.0.22631
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 3
1: Advanced Tables v0.19.1
2: Calendar v1.5.10
3: Tasks v4.9.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I apparently can’t operate the forum search. Thank you for linking this!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.