Vim mode global delete not processing correctly

Steps to reproduce

Using vim-mode for editing, in a file containing a lot of completed tasks (in this case, instances of recurring tasks), execute :g/^-\s\[x\]/d

Expected result

Matching lines are deleted

Actual result

:43d not an editor command (or some other line number).

Environment

  • Operating system: Windows 10
  • Debug info:
	Obsidian version: v1.0.3
	Installer version: v0.15.9
	Operating system: Windows 10 Enterprise 10.0.19044
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Obsidian gruvbox
	Snippets enabled: 5
	Restricted mode: off
	Plugins installed: 8
	Plugins enabled: 8
		1: Calendar v1.5.10
		2: Tasks v1.17.0
		3: Advanced Tables v0.17.3
		4: Vimrc Support v0.7.3
		5: Admonition v9.0.5
		6: Full Calendar v0.6.1
		7: Dataview v0.5.47
		8: Commander v0.3.0

RECOMMENDATIONS:
	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Download and reinstall Obsidian.

  1. Does it happen in the sandbox vault?
  2. Does it happen in source mode?
  3. Does it happen here https://codemirror.net/5/demo/vim.html ?
  4. Does it happen here https://codemirror-vim--util.repl.co/ ?

OK, I did a full uninstall/reinstall

I opened the sandbox vault, enabled vim mode, create a file with multiple lines of

- [x] Task

And then ran the same two commands. The first (global, but no delete) did return all the lines. The second (global with delete) still returned a variant of the same error (different line number)

I changed the sandbox vault to source mode, all results the same

I copied the text of my file into this demo, the results are the same.

I copied the text of my file into this demo, the results are the same.

Given all that, it seems like an issue in codemirror (which, if I understand correctly, is what Obsidian includes to get vim-mode?) rather than Obsidian itself.

If that’s correct, do you have any advice on how I raise a bug with them?

send a bug report or feature request here
https://github.com/replit/codemirror-vim

1 Like

Thank you.

I’ve got the same problem

Let’s leave it unsolved.

Ah, OK, I was marking it solved because the “solution” is “this is an upstream issue” and I’ve successfully opened a bug upstream for it.