Vim mode: Can't escape out of insert mode while typing link name (after [[)

Steps to reproduce

enable vim mode in obsidian.
enter insert mode.
type [[ and then start typing a link name
press escape

Expected result

vim insert mode is exited and one can move cursor with ghjk.

Actual result

obsidian remains in vim insert mode


Obsidian version: v1.0.0
Installer version: v0.15.9
Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:20:05 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T8101 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 8
Plugins enabled: 7
1: Advanced Tables v0.17.3
2: Dataview v0.5.47
3: Juggl v1.4.0
4: Mind Map v1.1.0
5: Natural Language Dates v0.6.1
6: Readwise Official v2.0.1
7: Notion-Like Tables v5.0.5

you need to press escape twice, one for the autosuggestion modal and one for vim.

Thanks. That does indeed work. Can I make this a feature request then? For vim users the current behavior can appear to be broken behavior.