Vim Block Cursor Not Visible In Code Blocks in Canvas Cards

Steps to reproduce

  1. Open the sandbox vault.
  2. Enable vim mode.
  3. Create a new canvas.
  4. Create a new card.
  5. Paste the following text into the card
```
foo
```
  1. Make sure to be in normal mode and place the block cursor in the code block. It will be invisible (seems to be behind it). If you enter insert mode the normal cursor renders fine.

Expected result

The block cursor is visible.

Actual result

The block cursor is not visible.

Environment

  • Operating system: macOS
  • Debug info:
SYSTEM INFO:
	Obsidian version: v1.1.8
	Installer version: v1.1.8
	Operating system: Darwin Kernel Version 22.2.0: Fri Nov 11 02:04:44 PST 2022; root:xnu-8792.61.2~4/RELEASE_ARM64_T8103 22.2.0
	Login status: logged in
	Catalyst license: vip
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none
2 Likes