Vault Switcher keeps coming up after every 20 seconds

Things I have tried

killing all process
kill cache

What I’m trying to do

Without more detail, not sure how anyone can help. This needs basic info: what operating system? How are you installing? You mention cache but don’t say which and where?

If you have time before the vault opens, hit Cmd-P to open the command palette. And then then type “debug” to run the command “Show debug info”.

Please paste the results of that command.

Do you have any hotkey or snippet apps installed, like BetterTouchTool, Karabiner Elements, Keyboard Maestro, etc?

You tried reinstalling, but this is a weird bug. You might have to delete your Obsidian preferences. You can find them under ~/Library/Application Support/obsidian on Mac. You can just try copying that folder somewhere safe, and then delete the entire folder, and try to reinstall Obsidian again.

1 Like

Obsidian version: v0.15.9
Installer version: v0.15.9
Operating system: Darwin Kernel Version 21.4.0: Fri Mar 18 00:45:05 PDT 2022; root:xnu-8020.101.4~15/RELEASE_X86_64 21.4.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


i just recently downloaded the application, so I dont have any hotkeys. I checked the application support folder and i never had the obsidian folder?

I saw your hotkey screenshot on Discord. (Assuming you’re the same person with this problem.) I didn’t ask about hotkeys. I asked about apps you’ve installed that might be triggering hotkeys or snippets.

Are you looking in /Library/Application Support or ~/Library/Application Support? It’s weird that your settings folder doesn’t exist. Unless there are other places it could be.

Did you download Obsidian from the official website?

Are there any other clues you can think of?

i downloaded this from the offical website