Using Gitdesktop + Github + ObsidianGit to backup vaults

I have stash my git folder on my second computer. It works so far…

Thanks

I got the same problem without the setting option.

Have you tried restarting Obsidian? That usually works for me.

I’v tried that, but it didn’t work. Thanks for your suggestion and I will try later again.

Try open developer console (ctrl + shift + i). See if your problem is the same.
If it is the same, then you need to install git client and add environment variables to system path

The problem appear again :confused:

git-error.js:31 Uncaught (in promise) Error: error: Your local changes to the following 
files would be overwritten by merge:
.obsidian/workspace
Please commit your changes or stash them before you merge.
Aborting

at GitExecutorChain.onFatalException (eval at evalFunc (app.js:1), <anonymous>:2302:85)
at GitExecutorChain.eval (eval at evalFunc (app.js:1), <anonymous>:2293:28)
at Generator.throw (<anonymous>)
at rejected (eval at evalFunc (app.js:1), <anonymous>:2247:65)

When pull changes to my computer 2.

My repository :

When you’re committing your changes are you using the obsidian git plugin or are you using git bash? You should be committing and pushing using the obsidian git plugin. It looks like you’re manually committing and pushing which may be why you’re running into issues?

How to do steps 9 and 10.
I am not able to find any toggles for switching it off after plugin is installed

Only the plugin :confused:

After you install the plugin. You should be able to access it in the “community plugins” section of your settings. You must turn the plugin on before you have access to “disable push.” Once you enable the Obsidian git plugin from the “community plugins” section it should pop up in the “plugin options” section of your settings. There you should find all the different things you can enable/disable.

Try asking in the discord. Im not sure how to best help you!

Thanks for trying :+1:

1 Like

@Samuo, Thank you for the detailed instructions.

Despite the fact that I use a Mac, I was able to translate a couple of commands and still follow your instructions to the letter – except I sync Obsidian (so I put the git folder in the Vault which resides in iCloud).

The only problem is, when I hit the “Commit all changes and push to remote repository” option, I keep getting a xcrun error.

I got the same error a week ago when I first installed Obsidian Git and tried to enable it. I uninstalled and reinstalled a number of times – both on the Mac and iOS app, but still got the same error.

I have checked my GitHub repo, after installing your way, and there’s just the one readme file that was created when I set it up.

Any thoughts on what I can do? Many thanks in advance.

Hi, after following all of the step, when I open my vault this message comes up. Not sure what do to or if anyone has a solution. Thanks!

Obsidian_bxasiIwb4m

Did you ever get this resolved? This error is because your version of CommandLine tools needs to be updated.

Has anyone run into issues accidentally committing files surpassing GH’s 100MB filesize-limit? I accidentally did so, and now I cannot push anymore because the erroneous commit will cause push to fail, resulting in the following error being issued in the console:

Uncaught (in promise) Error: To {{Private Repo}}
!	refs/heads/main:refs/heads/main	[remote rejected] (pre-receive hook declined)
Done
POST git-receive-pack (chunked)
remote: error: Trace: 34dc680e0a5ac373bec8f37ad91317c170d657a2f45caac50d76458691d0cfda        
remote: error: See http://git.io/iEPt8g for more information.        
remote: error: File 200 University/08 Internships and Universities/01 Internships/Meeting_JW.mp4 is 344.11 MB; this exceeds GitHub's file size limit of 100.00 MB        
remote: error: GH001: Large files detected. You may want to try Git Large File Storage - https://git-lfs.github.com.        
Pushing to {{Private Repo}}
error: failed to push some refs to 'https://github.com/Gewerd-Strauss/ObsidianVaults.git'

    at Object.action (plugin:obsidian-git:10679:25)
    at PluginStore.exec (plugin:obsidian-git:10704:25)
    at eval (plugin:obsidian-git:8499:43)
    at new Promise (<anonymous>)
    at GitExecutorChain.handleTaskData (plugin:obsidian-git:8497:16)
    at GitExecutorChain.eval (plugin:obsidian-git:8481:44)
    at Generator.next (<anonymous>)
    at fulfilled (plugin:obsidian-git:7333:24)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)#

Now, I know why this error is issued. But I have no clue how to fix it. The file itself is already removed from the vault, but that doesn’t seem to fix the issue.

If you’re using GitHub Desktop, does anything in the “Managing Commits” section on the left of this help document seem like it could help? If you’re on the command line only, look up git rebase (seriously, read about it before trying to use it!!) and see if you can get rid of your commit that way.