Usage of Ctrl+ commands, while typing on different language

Use case or problem

Ctrl+B, Ctrl+F, Ctrl+I and other hotkeys don’t work in case of different keyboard language layout. It is first time when I met this behaviour.
Usually these combinations works in any software in any keboard layout, so Ctrl+B (in rus layout will be Ctrl+И).

Proposed solution

I think that automatic behaviour of Obsidian should understand that if Ctrl key is locked, than the next letter would be a command, so I expect result of the command without changing keyboard layout.

Current workaround (optional)

Now I need to change language to En, press command Ctrl+XX and than change it back to Ru.

You can customize the hotkeys in Preferences → Hotkeys. Does this help?

Nope. I can change hotkey to russian layout, but then it stops working in en layout.

I would like you to pay attention that this is not expected behaviour, hotkeys should always work regardless of keyboard layout, Obsidian is the first software that behaves non-standard.

there is bug report already open for this.

1 Like