It might help devs understand what’s going on better by giving it a more specific return type. Maybe something like:
loadData(): Promise<Record<string, unknown>>;
or even better (since someone might be storing arrays):
I think that will also prevent people from adding
const settings = (await loadData()) || new MyPluginSettings().