Update 1.4.14 fails on Ubuntu

Hello dear community

As previously stated I’m on Linux, running Ubuntu 22.04 LTS.
The current installation was made through the Ubuntu Software GUI,
and has worked effortlessly for about a month.

Then just now, upon opting for the newest version, I get this error:
Unable to update obsidian: snap has no updates available

At the following link, someone recommends killall snap-store (for 20.04), but I’m always weary with trying out stuff like that.

Does anyone have any idea of what could be wrong here?
Is it a known problem, in which case I should apologize for even making this inquiry (although I wasn’t able to find anything directly related on here), or is something wrong on my end.

I know that the initial install wasn’t made through the appImage, but the app in Ubuntu Software is published by Obsidian, so…

I’m not entirely sure how I’d provide a more detailed guide reproducing the issue.
If it’s insufficient, please let me know!


moved to help for the time being. not clear, this sounds like an ubuntu issue right now.

It works now, for whatever reason