Unwanted automatic backspacing

In the obsidian editor, let’s say I type "dog " (with space). If I pause for a second, the editor automatically backspaces so the cursor is right after the “g”.

Similarly, if I type "- " for a new bullet, but pause, the cursor will go back to just “-”.

This is driving me crazy!

Things I have tried

  • Checked obisidan settings–did not find a feature toggle.
  • Checked the keyboard driver/settings
  • Doesn’t occur in any other application

What I’m trying to do

I would like to be able type "- " (with trailing space) and have the space stay there without the cursor moving to the left.

Paste your “Show debug info”.

Sounds like a plugin or a cloud sync issue. But one can only guess without more info.