Unintentional Korean character added at the beginning of a note

Steps to reproduce

  1. open any note and place keyboard caret(input cursor) inside the note
  2. press cmd + O(quick switcher) or cmd + P(command palette)
  3. type any Korean words
  4. press esc key

Did you follow the troubleshooting guide? [Y/N]


Expected result

Shouldn’t add any unintentional character.

Actual result

Unintentional character added at the beginning of a note.


Obsidian version: v1.4.16
Installer version: v1.4.13
Operating system: Darwin Kernel Version 22.3.0: Thu Jan 5 20:48:54 PST 2023; root:xnu-8792.81.2~2/RELEASE_ARM64_T6000 22.3.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information


I just realized this happens when I cancel search action as well.
Both ‘cmd + F(in note search)’ and ‘cmd + shift + F(vault search)’.