Uninstalled plugins only disappear after reloading Obsidian

Steps to reproduce

Delete a plugin.

Expected result

As soon as you click the “Uninstall” button the popup should go away and the plugin should be uninstalled

Actual result

The popup doesn’t leave the screen unless you click the x button to leave, and the uninstalled plugin only disappear after reloading the app


  • Operating system: Windows 10

  • Obsidian version: v0.12.15

This is a screen record of what is happening

This has already been posted by me before, but since I had no answer (the previous post was put in the bug graveyard) and this problem hasn’t been solved yet I decided to post it again.

Here is the link for the first post

Once again, post a screen recording of this happening in the help vault.

I already posted, just like last time

what you have attached is clearly not the help vault. I can’t reproduce this problem.
I need to see it happen when there are no themes a no other third party plugins.

The only way I can reproduce it in the help vault is to copy the plugin files from my vault to the help vault. But I did create a new one to try to figure out if it is a plugin, a css snippet or the theme I’m using that is causing the problem. After I reinstalled and reset each setting one by one It worked properly, but after some time it just came back for no aparent reason.

I also noticed that it happens in a new vault if I just copy and paste the same plugin files.

But here is a video of the problem happening in the help vault, and here is the plugin files that are in my current vault.

From Settings > About, what installer version is Obsidian using? The latest is v0.12.15. If you have being doing in-app updates, grabbing a fresh install from the Obsidian website might help.

Try with one or few plugins enable at time until you find the issue. Also checkout the console (cmd-opt-i ) and check for any errors.

It didn’t work. The problem is still there

There is this problem, but I don’t know what it means or how to solve it

you need to enable/disable the plugins in groups and figure out who is causing this.

I don’t necessarily think the depreciation is the problem.

I just did it, but it only fixes the problem if I reinstall all plugins from scratch in a new vault. Only enabling and disabling doens’t make any difference. And I don’t think this fix will last because I’ve done it once and the bug came back as I said before.

I am not looking for a fix here, I was looking to help you find which of your plugins causes this.

1 Like

What I meant is: none of the plugins neither snippets and themes are causing this because if I reinstall them manually in a new vault the app get back to normal. But I did it and the problem got back after a while.

After a lot of tests I noticed that this problem happens because of the Google Drive for Desktop app. When the plugin files are downloaded from google drive through Google Drive for Desktop or are being updated with the Google Drive for Desktop this problem happens. I tried uploading the files and then downloading through google drive’s website and they worked properly, so it’s not google drive itself. But when I upload a file to google drive through the website and download it using the app the problem shows up.

Overall the plugin files can’t be downloaded using Google Drive for Desktop, but if you upload them through the app and then download using the website it will work, the opposite won’t.

If anyone knows how to solve it without stop using Google Drive for Desktop let me know.