Unable to open Dev Tools / Inspector in Obsidian

This is a “had a problem, found a workaround” post for others who might encounter this, as well.

Things I have tried (before I found the workaround)

  • Googled for “obsidian cannot open inspector” (assumed that would cover the Obsidian help site, as well as the forum here)
  • Disabled plugins one-by-one, without restarting Obsidian in between, and attempted to open Chromium Dev Tools / Inspector
  • Tested capability in the sandbox instance (via Help → Open Sandbox Vault) and it worked there, just not in my main Obsidian vault
  • Searched for a Hotkey binding for CTRL+Shift+i - none found

What I’m trying to do

  • Open Obsidian’s Chromium Dev Tools / Inspector on Windows by pressing CTRL+Shift+i

What ultimately worked

On a whim, I disabled all Community Plugins via Options -> Community Plugins -> Restricted Mode -> Turn on. Tried the keystroke combo (CTRL+Shift+i) again but still couldn’t open Dev Tools. Left Restricted Mode on but closed Obsidian, then reopened.

I tried the keystroke combo again - this time it worked! Thinking this must be related to a plugin, turned Restricted Mode off to reload all of my plugins again. At this point, I …

  • Tried the keystroke combo: Success!
  • Restarted Obsidian (with Restricted Mode off/all of my plugins still enabled), then tried the keystroke combo again: Success!
  • Restarted once more to ensure this wasn’t some transient condition, tried the keystroke combo once again: Success!

So, to summarize, what worked for me:

  1. Enable Restricted Mode in Options/Community plugins (to disable all plugins)
  2. Restart Obsidian
  3. Disable Restricted Mode in Options/Community plugins (to re-enable all plugins)
  4. Restart Obsidian
  5. Profit
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.