Unable to log in with 2fa

Once you’ve done the above, delete everything above this line.

Steps to reproduce

  1. Download the macOS app from the website.
  2. Register on the website.
  3. Set up 2-factor authentication.
  4. Open the app. Go to “Preferences” > “General”.
  5. Click “Log in”.
  6. Fill in the email and password.
  7. Click “Login”.

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

I am logged in on my app.

Actual result

An animation of a disintegrating block plays. The log in window closes. I am back in the preferences and I am not logged in.
No errors are shown.

Environment

SYSTEM INFO:
Obsidian version: v1.6.2
Installer version: v1.6.2
Operating system: Darwin Kernel Version 21.6.0: Wed Apr 24 06:02:02 PDT 2024; root:xnu-8020.240.18.708.4~1/RELEASE_X86_64 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information

I am using macOS Monterey 12.7.5 (the latest available version at the moment).
I have logged out and back in on the website (not the forum) with the credentials that I tried to use.
I have reinstalled the app by downloading it from the website again and accepting the “replace” option.
I have also tried logging in with an incorrect password. The result is identical.

Can you post a screen recording of the failed login?

Are you SURE SURE that you are entering the same password?

Where in the world are you?

Do you get errors in console? (cmd-opt-i console tab)

For mac, download in install this

https://github.com/obsidianmd/obsidian-releases/releases/download/v1.5.12/Obsidian-1.5.12-universal.dmg

Does it still happen?

We reproduced. Will be fixed 1.6.3

The issue does not happen in 1.5.12.
I was able to successfully log in.

As a general remark, I am very disappointed that log-in behaviour was not tested in the newer versions.
I was trying to use Obsidian for the first time today. I created an account and downloaded the app just a few hours ago to give it a try.
It is unfortunate that this project is not well maintained and seems to contain unstable features. I really really hope it can become a reliable product in the future.

I’m glad it will be fixed soon.

1.6.3 is out …

1 Like

Wow! I’m really glad to see this issue being fixed so quickly.
Thank you so much!

1 Like