Unable to adjust or move around canvas items on iPad

Steps to reproduce

Create a canvas
attempt to drag around items
unable to drag the canvas itself moves and not the item.

Only way I am able to move around items is to resize them to the location where I want them.

Did you follow the troubleshooting guide?

Yes. On mobile so I toggled everything off, switched to the default theme and restarted obsidian. Also made sure it was up-to-date.

Expected result

To be able to move around any kind of object on the canvas.

Actual result

The entire canvas moves around.


Operating system: ios 17.0 (Apple iPad)
Obsidian version: 1.4.6 (105)
API version: v1.3.5
Login status: not logged in
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

Shared a video to discord but I also uploaded 2 videos here: iCloud Photo Sharing

Second video shares my entire setup and shows all of the troubleshooting I did. I did it again on video.

1 Like

Does it happen with the stable version of iOS?

I would have to completely reset my iPad from scratch using my PC in order to test that.

I can if no one on the team has a device already to test this on on iOS 16.6 BUT if you do, I’d rather not have to factory reset (been having other issues with a different software that I’ve had to reset for).

When did this started to happen?

Are you sure you are tapping and holding to trigger the element move?

I just started to use canvas after the beta for iOS 17 came out (so within the last month). So I’m not sure if it started before then.

Yes, I have tapped and held for 5 seconds before moving. I have tapped and held for 2 seconds before moving. I have tried it all.

So I wasn’t pressing and holding for long enough. I’ll mark this as solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.