Unable to access Community Themes

Dear fellow Obsidian users,

It’s my first day using this tool, and I have watched a few tutorial videos where I got to know that I could apply the themes created by others. However, I’m not able to access Community themes, please see the attached screenshot, indicating “Could not load Community Theme, please check your network”, while the network is working perfectly fine for other websites. Plus, I did turn on “Apply custom CSS” setting.

Much appreciated.

Do you have a firewall? It may be blocking it.

Hi there, thanks for replying. I have tried to turn off the firewall, but the result remains the same. One more thing weird is that, when I tried to join the Discord server, I’m unable to even enter my birtday, not sure if it’s because of my IP address (one of the possible reasons as indicated in the description why Discord server is not accessible) or what…

Can you access other servers on Discord?
This may be a long stretch, but do you have connectivity in any other electron-based app? Slack, GitHub Desktop, VS Code, etc.?

Hey, indeed I think it’s bcz of where I am located. I cant download Github Desktop…
But now the problem is solved. :smiley: I managed to contact the staff or developer from Obsidian via Twitter, and they offered me a solution of changing my host files, which could solve the connection issue.
Anyway, thank you for trying to assist~

1 Like

Hi, there, I am in China, and I have the same problem with you. Would you please tell me how to change the host file?

I have the same problem, and doesn’t work even with VPN. Is there a way to download files from github and manually switch the theme?

  • I’m in China too. Maybe your firewall is open