Two Annoyances Since Switching Away from the Legacy Editor

I am running Obsidian 0.14.15 on a Mac and using the Minimal theme. Anyone know how I can remove the two annoyances described below?

One

I have a few notes that are collections of a header line followed by a list. For instance, I keep a running record of my Wordle games in a note using the following format:

## 2022.07.13
   + LEAST (A green; L yellow)
   + PLAID (L,A,D green)
   + BLAND (solved)

## 2022.07.14
   + LEAST (L green; E yellow)
   + LINEN (L,I,E green)
   + LIVER (solved)

## 2022.07.15
   + LEAST (E green)
   + PERCH (E green)
   + BENDY (E green; D yellow)
   + WEDGE (solved)

When switching to a note like this, the cursor starts positioned at the beginning of the note, but I need it at the end. Fortunately there’s a shortcut (CMD + DOWN ARROW) that moves the cursor to the last character and scrolls the note to end. This worked perfectly in edit mode of the legacy editor. With the source mode of the new editor, however, I find that while the shortcut key combination still moves the cursor to the end, it only scrolls to just before the line containing the last header. So, if the example above was at the end of a much longer collection of such entries, pressing the key combination will move the cursor to line after ‘WEDGE’, but it only scrolls far enough to show the line after ‘LIVER’. I then have to manually scroll the rest of the way.

Note, I do not see this same odd scrolling behavior in notes that have a couple header lines at the top which are then followed by many paragraphs of text. Pressing the key combination on those does the correct thing.

Two

I have a Templater template that I run daily. One of the things it does is position the cursor a the end of the line where I need to start typing. Since switching to source mode, the cursor ends up a the beginning of that line instead of the end.

RE: two
I have had issues with Templator’s tp.file.cursor recently, though I am mostly in Live Preview. Guidance I have seen from others includes making sure you are passing the right number, likely 0, to cursor(). I have also done the opposite - not passed a number, which leaves the cursor bit still in template format, and then hotkey the command “Templater: replace templates in current note” which then successfully moves my cursor since it is the only templated item left in the file.

PS: A recent Obsidian Roundup said that Templater’s maintainer was looking for others to pass it off to, so I doubt there have been many issue fixes recently. Perhaps you could solve the cursor issues for all of us and submit a patch to the plugin?

The documentation for Templater says the cursor can take an optional number parameter called ‘order’. I’ve no idea what that represents. I’ve tried cursor(), cursor(0), and cursor(20) but all leave the cursor at the beginning of the line.

It looks like this problem (TWO) is a bug (tp.file.cursor() puts the cursor at the beginning of the line if there are greater than 65,536 (2^16) characters) in Templater rather than a problem with using the new editor. The note I’m working with exceeds this limit.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.