Transclusion within a callout doesn't update

Steps to reproduce

If I embed a transclusion inside an Obsidian callout then it does not update itself in place until I close the note and open it again.

This is a minimal example β€” if I edit then it only updates in the transclusion outside the callout:

# This is a section
With some content

# This is a transclusion outside a callout:
![[#This is a section]]
This does update

# This is a transclusion inside a callout
> [!TODO]
> A callout, but transclusion does not update
> ![[#This is a section]]

Expected result

I would expect to see the transclusion update as it does outside a callout.

Actual result

The callout does not update the transcluded content!


  • Operating system: macOS 12.4; Obsidian v0.14.6
  • I tried the above in a sandboxed vault and the bug still exists.
  • Debug info:
    Obsidian version: v0.14.6
    Installer version: v0.12.3
    Operating system: Darwin Kernel Version 21.5.0: Tue Apr 26 21:08:22 PDT 2022; root:xnu-8020.121.3~4/RELEASE_X86_64 21.5.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Minimal
    Snippets enabled: 2
    Safe mode: off
    Plugins installed: 45
    Plugins enabled: 41
    1: Calendar
    2: Excalidraw
    3: Natural Language Dates
    4: Kanban
    5: Templater
    6: Citations
    7: Hotkeys++
    8: Obsidian Charts
    9: Tag Wrangler
    10: Plugin Changelogs
    11: Hotkey Helper
    12: Paste URL into selection
    13: Readwise Official
    14: DEVONlink
    15: Hider
    16: Obsidian42 - BRAT
    17: Copy as Latex
    18: Lumberjack :axe: :wood:
    19: Highlightr
    20: Get Info
    21: Pandoc Plugin
    22: Mind Map
    23: Copy button for code blocks
    24: Obsidian42 - Jump-to-Date
    25: Tasks
    26: QuickAdd
    27: Buttons
    28: Omnisearch
    29: Daily notes opener
    30: Obsidian42 - Text Transporter
    31: Customizable Page Header and Title Bar
    32: Advanced Tables
    33: Advanced URI
    34: Outliner
    35: Minimal Theme Settings
    36: Style Settings
    37: Dataview
    38: Timeline
    39: Tracker
    40: Workspaces Plus
    41: Zoom

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

Have you tried with insider build?

1 Like

How about that β€” I don’t tend to want insider builds running, but that indeed fixes. Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.