Todoist Error: Unable to parse as YAML or JSON

What I’m trying to do

I’m trying to get Todoist Sync plugin queries to work

Things I have tried

I have the plugin installed and I have been able to add tasks with it; so my API key is correct. I’m following examples that I have found in various articles, but I keep getting this message about “Unable to parse as YAML or JSON”. Even a simple query like this fails:

name: A Name
filter: overdue

I’ve tried with quotes around the various elements and without. I’ve tried indenting with tabs and spaces. It doesn’t seem to matter. Am I (hopefully) doing something terribly wrong? I have my vault on Windows and Android, but I’ve been testing this just on my Windows desktop.

Thanks for any suggestions.


I’ve not used that plugin, but the example section on the plugins homepage, see GitHub - jamiebrynes7/obsidian-todoist-plugin: Materialize Todoist tasks in Obsidian notes suggests it should look like the following:

name: A name 
filter: overdue

Thanks, I was either too tired when I posted, or the three backticks and toodoist at the beginning and the three backticks at the end were cutoff by the forum editor. I am including those in what I try in Obsidian, but I keep getting that message. I appreciate the help.


For some reason this fixed itself. When I opened Obsidian this morning, the todoist inserts all worked… Thanks for the help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.