The tab key is ERRER!

Things I have tried

The tab is not Leave two spaces what i want ! :sob: :sob:
And,have been changed this that like
image
what should i do change this situation,help me please! :sob:

What I’m trying to do

Hi, have you tried disabling “Use tabs” and setting “Tab size” to 2, with the slider?