The synced 'iCloud for Obsidian' folder cannot be accessed from other Apps

The red box is the synced folder that was created from my iPadOS Obsidian. This whole folder is grayed out in iCloud so that other apps cannot access it (like exporting files to this folder, and reading .md files from this folder).

This only happens to the Obsidian App folder. MarginNote3 is also an iCloud App folder but I can access them just fine (not grayed out, as shown in the image above).

I have also experienced this issue. The workaround was to save to another directory and then move the files into Obsidians directory with the Finder.

Thank you. But my issue is the file I need to move in is actually synced automatically, and copy&paste breaks that syncing.

More context: I’m using the “Citations” Plug-in, which requires a feeding of a .bib file, and I use the ‘automatic-export’ feature from BibLaTex (a Zotero plugin) to automatically sync my most up-to-date citation files for the Obsidian Vault to extract.

And now, my Zotero cannot open this magic folder, which makes this whole workflow obsolete.

I guess I’ll have to wait till this problem is resolved by the developer, in order to ‘sync bibliography’.

Please reinstall Obsidian from the website. I believe 0.12.10 fixed this issue, but the installer itself needs to be updated, which requires a manual reinstall.

Let us know if that works!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Reopened due to a message from @louisa—apparently this is still an issue.

@louisa We need clearer details. What devices/operating systems and apps cannot access the folder? Which ones can?

Thanks for reopening the issue and for the help.


For the Obsidian folder in iCloud (created by my iPad app):

  • iMac, Big Sur version 11.4.
  • Local file system access can access normally
  • VS Code can access normally
  • Zotero 5.0.97-beta cannot export files to it. Behavior: the folder appears to be gray.

Tried but didn’t work:

  • delete the folder, re-create it from the iPad’s end
  • empty the folder
  • reinstall Obsidian on iPad and repeat the two processes above.

Having this issue too (Mac running the latest version of Catalina). It means I can’t add CSS snippets to the snippets folder, among other things.

What installer version are you both using? It’s found in Preferences→About.

Does the following information tell you my installer version? If not, could you elaborate on “Preferences→About”?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">
<string>1983-2021 Apple Inc.</string>

No, I’m not sure what that is, heh.

In Obsidian, go into your Preferences, and then click on “About” in the left sidebar. There’ll be a display like:

Ah I see.

My installer is v0.11.9, and the app version is v0.12.10

Reinstall Obsidian from the website ( to update the installer version. You should no longer have this problem. Let us know if that fixes it.

Worked like a charm! Thank you so much!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.