Text overflow on lists and checkboxes is inconsistent and space inefficient

Steps to reproduce

Make a bulleted list like:

- reallylongwordreallylongwordreallylongword
- [ ] reallylongwordreallylongwordreallylongword
- https://reallylongurlreallylongurlreallylongurl.com
- [ ] https://reallylongurlreallylongurlreallylongurl.com

And then shrink the editing and previewing windows until reallylong* wraps around.

Expected result

… something consistent. personally I find - \n reallylong... strange in all cases, I’d prefer to not have the preceding newline ever.

A long-word-preceding newline makes perfect sense when there is non-whitespace before the word, but not really when there’s “nothing” else.

Actual result

inconsistent rendering:

  • Bullets with and without checkboxes “prepend a newline” (or <br> or whatever) to the text when editing, but only to checkboxes when previewing
  • URLs do not prepend a newline when editing or previewing
  • URLs with checkboxes prepend a newline only when previewing

Auto-indenting, folding, readable-width, and line numbers do not have any effect on this. And I’m using the default theme, if that matters.

Example screenshots:
Editing:


Previewing

Environment

  • Operating system: OSX 10.15.7
  • Obsidian version: v0.10.6
2 Likes

Screen-space inefficient wrapping of links in edit mode

Steps to reproduce

  • original text for reproduction:
- some text
	- [C:\Users\Me\Desktop\2020\this_is_some_very\long\path\My_Very_Long_File_Name.xlsx](file:///C:/Users/Me/Desktop/2020/this_is_some_very/long/path/My_Very_Long_File_Name.xlsx)
	- [C:\Users\Me\Desktop\a little bit shorter path\Wraps_Correctly.xlsx](<file:///C:/Users/Me/Desktop/a little bit shorter path/Wraps_Correctly.xlsx>)
  1. Paste the text from above to Obsidian.
  2. Set pane widths as seen in screenshot shown under header “Actual result”.

Expected result

  • Wrapping immediately after list-item marker "- " is unnecessary in case like the following since the rest is wrapped again anyway.

Actual result

  • On Windows7 in Obsidian 0.9.11 it looks like this:
  • Rendered in preview mode wraps correctly but in edit mode: One line of valuable screen-space is wasted on each similar item; The list can occupy up to 50% more space when each item contains one wrap.
  • It seems to be imperfection/simplification in wrapping logic. Or is there any good reason to do it like this?

Environment

  • Operating system: Windows 7
  • Obsidian version: 0.9.11 (and also previous versions)

Ah, there was a similar one. Thanks for finding that! I didn’t guess the correct keywords apparently.

This is sorta a superset I suppose, as there’s also variance between text and linked-text.

Steps to reproduce

  1. Edit a note in editing view (legacy mode)
  2. Enter a bullet point and very long line of text, for example
    “- AVeryLongLineOfTextAVeryLongLineOfTextAVeryLongLineOfTextAVeryLongLineOfTextAVeryLongLineOfText”

Expected result

Line break should happen as in preview mode (include bullet point in line before break in middle of the word):

Actual result

Line breaks after bullet point AND in middle of word:

Environment

  • Operating system: Windows
  • Debug info:

SYSTEM INFO:
Obsidian version: v0.13.17
Installer version: v0.12.19
Login status: logged in
Catalyst license: vip
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Safe mode: on

RECOMMENDATIONS:
none

I have encountered the same issue. Not sure how to get a summary of the system info, but here are the key items:

  • Obsidian version: v0.13.18
  • Windows 10, desktop
  • Theme: Minimal by kepano

The problem, in editing lists the unordered list bulled icon is off (too high)

kuva

In read-view it looks correct
kuva