Text Doesn't Type Right Away in Edit Mode

This past week, I’ve started having issues when in edit mode and I’m not sure what is causing it or how to correct it. Basically, when I click to type, the characters I type don’t appear on the screen until I type a bunch of letters but then they overwrite the text that was previously in the note.


  1. I open a note in edit mode and click to edit
  2. The cursor is there but it is a bar which is wider than what a cursor would be. I start typing and nothing seems to happen. After typing a character, the bar starts going backwards then after a bunch of characters, text starts to (over)write.

So weird and I’m not sure how best to explain it. I must have a setting on or something. Has anyone experienced this and know what the fix it? It only occurs in Obsidian and not other apps.

1 Like

You just discovered (by accident) the power of vim-mode, which if turned on by accident without learning it, can be really annoying.

Vim allows for every key in your keyboard to be a shortcut, hjkl work like the arrows.
h is ←
j is ↓
k is ↑
l is →

i is insert mode. This means that you can start writing once you click i and when you press esc you get back to vim mode.

when you press random keys you end up pressing i or a and then you are in writing mode.

d and x delete things so you where accidently pressing them too.

I highly recommend learning it, since it can allow for some really quick text editing experience. But of course right now it’s being annoying, so for now just turn it off.

Go to:

Settings > Editor > (scroll down to the bottom) “Vim Key bindings”
turn it off.

That solves it!


Thank you so much for clearing this up!

1 Like

my pleasure! glad I could help

1 Like