Tables incorrectly render whitespace

Steps to reproduce

  1. Create a table in source mode, adding extra spaces between words/letters
  2. Enter Reading view to see the extraneous white space rendered

Table Source

Did you follow the troubleshooting guide? [Y/N]

Yes

Expected result

No extraneous white space.

Normal Reading View

Actual result

Extraneous white space.

Table Reading View

Environment

SYSTEM INFO:
Obsidian version: v1.5.8
Installer version: v1.4.16
Operating system: Windows 10 Pro 10.0.19045
Login status: not logged in
Insider build toggle: off
Live preview: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 4
Plugins enabled: 0

RECOMMENDATIONS:
none


Additional information