Tables don't render in live preview unless there's a blank line above

After the 1.3.2 update, all of my tables were showing up as text in live preview mode, instead of rendered tables as they did. I realized after digging around a bit that the tables render only when they have a blank line above them. This wasn’t the case in most of my files because I prefer to add them right after a title.

Steps to reproduce

  • In live preview mode, start adding a table on a line right after any content (heading, text, doesn’t matter)
  • Finish adding table

Expected result

  • The content should show up as a table once the cursor is outside it

Actual result

  • The table content just shows up as text, unless I go and add a blank line above it. Then it shows up as a table once the cursor is outside it.


Obsidian version: v1.3.2
Installer version: v1.1.16
Operating system: Windows 10 Home Single Language 10.0.22621
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

Additional information

Without blank line above

After adding a blank line above

This is intentional. Not a bug.
See here on the Obsidian Discord Channel: Discord

1 Like

Oh, I didn’t realize this was a markdown requirement. I’m not thrilled about the change, but I understand the reasoning.

How do I close this thread? Sorry, new to the forums, so still figuring things out.

You already found the answer :slight_smile: By marking an answer as the solution.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.