Table renders in editiing mode (live preview) but not reading mode

Steps to reproduce

The following markdown:

question words:
| eng | fr |
| - | - | 
| who | qui|
| when | quand |
| what | que |
 | where | où |
 | why | pourquoi |
 | how | comment |
 | how much | combien |

Expected result

Table should also render in reading mode.

Actual result

Editing mode (when moving cursor out) (expected behavior):

Reading mode → table should also render here

Environment

  • Operating system: Ubuntu
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.14.6
    Installer version: v0.13.31
    Operating system: #49~20.04.1-Ubuntu SMP Wed May 18 18:44:28 UTC 2022 5.13.0-44-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Safe mode: on

RECOMMENDATIONS:
none

Put a space between the question words: and the first row of your table.

question words:

| eng | fr |
| - | - | 
| who | qui|
| when | quand |
| what | que |
 | where | où |
 | why | pourquoi |
 | how | comment |
 | how much | combien |

Yes, I know how to fix it, but shouldn’t preview mode and reading mode be consistent? Maybe I should phrase the bug report differently…