Table Plugin: Can't open table menu

I’ve installed the table plugin. When I want to open the table menu I always get the message “Cursor must be in a table”. But the cursor is in a table. Doesn’t work with the shortcut and not with the toolbar. Obsidian V0.10.1 and advanced table 0.7.0

I’m having the same issue. Obsidian 0.10.1, Advanced Tables 0.7.0 with a modified Obuntu CSS

Not sure if I am remembering correctly, but I think I had the same problem when I first installed it.

Also not sure if this was the solution/correction to my error that fixed the issue, but, after installing, did you double check in the settings that you actually move the toggle for Advanced Tables to Enable? If not, try it. Don’t quote me on this, as things may have changed since a month ago, but hopefully this helps.

Good luck. I’m sure you will get it working. Great plugin.

thank you, yes, i do have it enabled

It would probably help you if you could open an issue with the author or contact them through Discord. Most of us probably don’t have the ability to debug third-party plugins, unfortunately.

same, it has been installed for a month but never worked once… what’s wrong? can anybody help?

Hey, sorry I did not see this message earlier! Please don’t hesitate to open questions on the issue tracker or ping me in Discord if I miss messages like this.

But anyway, can you show me an example of a table that is not working for you? The plugin requires the table have pipe characters on the outside edges of the table, like this:

| One | Two |
| --- | --- |
|   1 |   2 |

A table like this will not work

One | Two
--- | ---
  1 |   2

Let me know if that fixes the issue for you, and if not, what your table looks like. Thanks!

4 Likes

ah, the outside edge thing did the trick! thanks so much! can’t wait to use this!

it works really well now! Thank you for bringing us this amazing plugin. Can you please add it to the readme file so that more people mistakenly use it like me can figure it out?